FirebaseError: Missing or insufficient permissions




Both a colleague of mine and I keep getting the following message for the first 10-30 seconds when we try to view the list of public charts : 


“Could not load charts

FirebasError: {code=permission-denied]: Missing or insufficient permissions.”

After some time, the list of public charts appear. This time interval can vary between a few seconds and up to over a minute. Other colleagues of us are not experiencing this issue. 


It seems strange that the error only occurs for a short time, but it reappears every time we try to open public charts. We have tried deleting all cookies in the web browser without this affecting the issue.


Do you have any clue what could cause this?



Best answer by Marit Owren Valmot 13 May 2022, 16:44

View original

6 replies


I am currently enabling OIDC in our system and then get exactly the same problem as you are describing.  So I am also very interested in finding out what is causing this error.

Userlevel 5

Hi @Marit Owren Valmot and thanks for calling this to our attention. This is the third time we’ve heard about this, which absolutely raises the priority of fixing this bug.

This is actually a known issue that @Håvard Knappskog first notified us about several weeks back. @Pedersen Jon-Robert – thanks for jumping in here too – messaged me last week saying he had the same issue, which was the second time we learned of it. 

We’ve done lots of investigation on our side into all possible theories as to why this issue might be. It’s not related to missing/changing access rights, usernames or user IDs changing or not matching between legacy ↔ OIDC, ++...

To be honest, we still have not determined what the problem might be. We now suspect that it’s a broader authentication “edge case” that affects those who are used Charts on legacy authentication and migrate to OIDC. This isn’t something that other Cognite products or applications have experienced themselves either, but we’re now reaching out to other Cognite teams to escalate this issue. 

In the meantime, we do have a temporary workaround, assuming it’s still possible to log in to your organization’s CDF project using the the Sign in with project name button (see screenshot below):

If you  log in with that “old” method, you should be able to see and access all of the existing charts that you or others have created. Although keep in mind that, for now, if you create a new chart after logging in using OIDC, it may not appear in the legacy project. We will ensure that all charts created when logging in with legacy authentication will be available for you through OIDC login, once we’ve resolved this issue.

We apologize for the inconvenience, but we really appreciate your patience as we get to the bottom of this problem. As soon as we have more updates to share, I’ll post here on Cognite Hub and reach out to you all directly. 

If you have any questions or would like to have a call to discuss further, feel free to send me an email ( or calendar invitation.

And once again, thanks for reaching out about this!

Eric & the Charts team


Thank you for the update, @Eric Stein-Beldring . It will be interesting to folow this topic, and hopefully learn what causes this. 


For my use, I can live fine with this issue for now, as it is usually gone by the time I have refilled my coffee :)


Thank you to you and the team for making a very useful product, and I appreciate the quick response. 




Userlevel 5


We pushed a potential fix that may resolve this issue. 

Could you all following this thread try logging in again and see whether you get the same error?

If you still experience the same Firebase error, then we’ve added a simple step to help us get the additional information we need to finally get to the bottom of this. To get this information, please follow the steps below (see GIF):

  1. Click on your user profile icon in the top right corner.
  2. Choose the Profile option from the menu.

  3. Open the Advanced information dropdown.

  4. Copy or screenshot all of the contents in that dropdown and share them with me over email directly: Please do NOT post this information in this thread, as it may contain private information.


Thanks everyone!

Userlevel 5

Another update:

While the previous update didn’t fix the issue, that helped us to discover another possible culprit for this bug. 

We’ve deployed a new update to Charts and would like you all to try logging in once again and let us know whether the “Firebase error” still occurs.

Again, thank you all for the patience and help!


Hi, I do not get the Firebase error any more, so the problem seems to be fixed .