Solved

How do you delete a (data model) space? [Community Contributed]

  • 24 April 2023
  • 3 replies
  • 129 views

I created a test data model in a test space. I finished testing and deleted the data model, but can not find a way to delete the space (which no longer contains any data models)?

icon

Best answer by Thomas Sjølshagen 8 May 2023, 14:46

View original

3 replies

Userlevel 3

Hi @Arnfinn,

Not sure if you’re trying to use the “Data Modeling” UI in Fusion or if you’ve already tried the /api/v1/projects/{project}/models/spaces/delete API endpoint?

 

If you’ve tried in Fusion, I’m sorry to have to let you know that we do not yet have support for space deletion there (yet), so you’ll need to use a POST operation to the /api/v1/projects/{project}/models/spaces/delete endpoint, specifying an array of space IDs to delete in the request body

 

If your attempt was using the endpoint, it would be helpful to get a request ID so we can try and figure out what’s going on.

 

Thanks!

I was using the UI in Fusion, thank you for the answer.

Userlevel 4
Badge +2

Hi @Arnfinn,

We appreciate your contribution to our community hub! We have chosen to move your article to our hub's How-To section as it will greatly benefit other members of our community. Thank you for your understanding, and we look forward to seeing more great contributions from you in the future! 

Best regards,
Dilini 

 

Reply