Solved

PI Extractor and Extraction Pipelines

  • 20 September 2023
  • 7 replies
  • 100 views

Badge

Hi, we are using the PI Extractor with Extraction Pipeline and is pushing the config through the pipeline.

But we noticed that after updating Config in extraction pipeline we have to restart the PI Extractor  to force it to use the updated config.

If we update the config we can se in run history that the extractor is reporting “Seen” on the new config revision but it is not loading and using the new config.

Is there a way to force it to use new config?

icon

Best answer by Dilini Fernando 30 November 2023, 09:01

View original

7 replies

Hi Jon, 

Would this be a similar feature request as the following: 

 ? 

Thank you, 

Kat

Badge

It is similar but not the same.

We specify in the config  wich tags to extract:

          extractor:
                 include-tags:

                           - nnnnn.nnn.nnn

 

When we add a new tag to the config we still need to restart the extractor service to get it to pick up the new tag.

The Pi extractor should detect a new config and restart itself within a few minutes. How long are you waiting before restarting it manually?

Userlevel 3

@Pedersen Jon-Robert, do you need any further follow up from us? 

Badge

Its not working, but we made a workaraound with a script that is sniffing for changes and restarts the Pi Extractor service if it finds a new configuration.

Userlevel 3
Badge +2

Hi @Pedersen Jon-Robert,

We are checking in to see if you were able to solve the problem with the workaround.

Best regards,
Dilini 

 

 

Userlevel 3
Badge +2

Hi @Pedersen Jon-Robert,

I hope the above helped. I’m closing this topic now, please feel free to create a new post if you still experience problems.

Best regards,
Dilini

Reply