Solved

DB Extractor Polars CPU Check Failed. Troubleshooting Ideas

  • 8 May 2024
  • 5 replies
  • 113 views

Badge

Hello,

 

When I tried to run the DBExtractor, I get the following error: 

“polars\_cpu_check.py:232: RuntimeWarning: Missing required CPU features.

The following required CPU features were not detected:
    avx, avx2, fma
Continuing to use this version of Polars on this processor will likely result in a crash.
Install the `polars-lts-cpu` package instead of `polars` to run Polars with better compatibility.

Hint: If you are on an Apple ARM machine (e.g. M1) this is likely due to running Python under Rosetta.
It is recommended to install a native version of Python that does not run under Rosetta x86-64 emulation.

If you believe this warning to be a false positive, you can set the `POLARS_SKIP_CPU_CHECK` environment variable to bypass this check.”

After doing some googling, I was able to install the polars-lts-cpu package referenced using python, but I got the same error. I’m not sure how to make the extractor reference the polars-lts-cpu package when it runs. See attached screenshot.

The extractor is running on a virtual machine with Windows Server 2019 OS with two CPU processors and 4 GB of RAM. The extractor I downloaded is dbextractor-v3.3.4.msi. 

The processor for the VM is an Intel Xeon CPU E5-2630. I’ve seen on some other forums that Polars may be incompatible with this type of processor, but I’m not sure if there are any workarounds. 

Any ideas on how I can bypass this error?

Thank you

Matt

icon

Best answer by Rogerio Júnior 7 June 2024, 12:57

View original

5 replies

Badge

Hello,

 

Version 3.4.2 of the db extractor resolved the error I was seeing. Thank you for the suggestion. 

Hi Matt,

Thanks for reporting this. Can you please open a ticket with our Support team? In this way we can expedite the investigation of this issue internally. 

Thanks a lot

Rogerio Junior
Cognite Engineering

Userlevel 4
Badge +2

Hi @MRegel,

A support ticket has been created on your behalf.

Hi,

We released version 3.4.2 with a fix for this issue. Can you please test and let us know the results?

Thanks

Rogerio Junior
Cognite Engineering

Badge

Absolutely! Will I need to change the config.yml file to be compatible with the new version?

Thank you for the update. 

Reply