Change name of dataset

  • 23 December 2021
  • 4 replies

Userlevel 2

We would like to change a name of our dataset in Fusion (specifically data set id=7661001648160088 on statnett, test), but get the error message

[  {    "status": 400,    "message": "Either set must be populated or setNull must be true."  }]`


The dataset has related timeseries and asssets. What does it mean that the dataset must be populated? And what are we missing?


Best answer by Viraj Dhanusha 27 December 2021, 00:17

View original

4 replies

Userlevel 2
Badge +1

Hi Anders

It’s Viraj from Cognite Support and thank you for contacting us. 
I have tried to reproduce your error and I could reproduce this error when updating the dataset name as
"name": {"setNull": true} and then try to revert it back as  "name": {"setNull": false}
Have you done the same thing or was it different ?
Can we know how you tried to change the name of the Dataset?(via Fusion UI, API(Postman) or SDK)
Have you got a request-id for this error, if so please share with us.

Also can you explain what you were trying to do to the dataset name (string)? (change the name / remove name/ setting empty etc)

With regard to the meaning of the error and missing inputs, I need to come back to you with the help of the engineering.


Userlevel 2

Hi, thanks for the reply.

I tried using Fusion, and the error is due to the requirement of both a name and description. When the description is empty (NULL), the error occurs. 

A better input check in the frontend should be implemented to fix this. Even though there is an asteriks (*) after description, its not that easy for an end user to understand the error message.




Userlevel 6

Hi @Anders Willersrud thanks for your valuable feedback! Could I suggest you submit your suggestion for a better input check in the frontend, as an idea in the Product Feedback section here on Hub? This way other users can upvote on your idea. Ideas posted in the Product Feedback section will be fed straight to our product teams as well:)

Userlevel 2



I created the suggestion here: