Getting error message "Selected recipe is invalid" when trying to create a new transform job

  • 14 March 2022
  • 4 replies

I am following the course “Working with CDF: Integrate” and I am currently trying to create a transfrom job for the IFSDB data set. The problem is that when I go to “Schedule and run” after I have run the preview, I get an error message saying “Selected recipe is invalid. Starting av transformation job is at your own risk.”, and the Transform-button is unavailable.

Please advise.

Lars Kjetil Sørhus


Best answer by Madina Kholmatova 14 March 2022, 12:43

View original

4 replies

Hi Lars Kjetil, 

You can disregard the warning message, because since the recipe is valid without the ID column and you can  continue with transformation. Make sure you select the right destination type when running the transformation, I have tested your "Kjetil1964-Timeseries" transformation, selected  the right destination type and seems it is working and ready to transform. Please check on your end! 

Let us know if it doesn't work and share your particular transformation name and screenshot of your screen. 

Best regards,

Hi Madina.

Thanks for the quick reply!
I managed start the Kjetil1964-Timeseries transformation now, but I still get the same error message for the “Kjetil1964-IFSDB” transformation job as descibed in the OP.



From the SQL code, I see that you are transforming RAW to events. So I selected events as destination type and transform button is available. Also, you can rename your transformation "Kjetil1964-Events" as per course instructions says so it will be easy for you to find later on. Please let us know if it works!

Best regards,



Thanks again! I manages to miss the “Evens”setting, and this solved the problem :)