I am struggling with logging in through the CLI

  • 7 March 2022
  • 1 reply

I tried logging in with these commands:

platypus login --cluster greenfield --tenant "schema-test"

which didn’t work as I thought the tenant was a CDF tenant and not an Azure AD tenant.


Then I tried:

platypus login --cluster greenfield --tenant "c08c2afd-4823-482b-9113-ed2746fe6026"

Which gave me a “Login successful” webpage, but the CLI said: “failed to authenticate against CDF project: platypus”. Then Soumesh pointed out that platypus is the default project, and I needed to type:

platypus login --cluster greenfield --tenant "c08c2afd-4823-482b-9113-ed2746fe6026" schema-test

Which worked :smiley:

I think having default values made it harder to use as the CLI didn’t guide me on missing project name / CDF cluster etc, and maybe a better name than tenant as it can be interpreted as CDF tenant/project.

1 reply

Userlevel 4

Hi Fredrik,

This is a great catch! We will improve our error handling by providing a clearer error message and by removing this “default” for project name.

Please let us know if there’s anything else 🐞-y